Vega G2 Max volume set up

#1

I wonder if I am the only one bothered by the fact that the volume on the Vega G2 goes back to the MAX to any given source when you switch sources. It is a great feature that one can set a maximum volume for each source. So, I regularly listen via Ethernet at 55 but some of my streamed or, mostly, NAS music need to go higher to 80 therefore are set this source max volume to 85. After switching to another source and returning to Ethernet the volume goes directly to the MAX (85) which is blasting loud for 80% of my listening…!!! Is there anyway to have the volume START to the most common level for any given source that is not the maximum set by the user and let the user increase it to the level needed?.
In other systems MAX is not the default, is the maximum level allowed based on your setting but there is also a START volume which is also set by the user based on the most common usage. It would be so helpful !!!

#2

Have you checked if the volume mode has been set at master or individual? I am not sure if it will affect the max volume function but you can try and change it to individual. The individual option allows each input channel to have its own volume number so when you switch between different channels, the setting will be remembered.

#3

Thanks Xuanqian, I have it set as individual. It does not matter what I do, when I return to Ethernet source, it defaults to the max which, as I said, it is too loud for a lot of my streaming…

#4

But low for some of it

#5

Just confirmed, this is a bug of the firmware when we introduce the max volume feature, this is going to be fixed within a couple of weeks.

#6

Thank you very much, it will be a great help for my listening and the health of the speakers,