Streaming over Wi-Fi for the BEST sound quality!

I’m very much invested in the idea of streaming with AURALiC because they believe that streaming over Wi-Fi can - in the right circumstances - sound equally good if not better than Ethernet (this saves money on stupidly expensive hi-end Ethernet cable too).

So - help needed from my end - I have changed by broadband provider to TalkTalk - and they have this new super router getting excellent reviews. And I agree, the reach is better and speeds over wireless distance are better too using this router. But… with the AURALiC Mini …

I’m sure the sound quality is not so good with streams over Wi-Fi (even though there are no drop outs) and also I find that the Lightning DS app on my iPhone loses connection more with the Mini when I am trying to slide the software volume control up and down.

Every other device in my household is working solidly. With my previous more dedicated NetGear router the AURALiC sounded better (I think), and kept the Lightning DS connected with the Mini - but with those 6x aerials sticking up was far more ugly.

That ‘should’ not be the case though - because the TalkTalk router is of a very high specification - see here: https://www.ispreview.co.uk/index.php/2018/05/new-and-faster-wifi-router-spotted-at-broadband-isp-talktalk.html

  • No. of antennas = 7
  • Wi-Fi bands (2.4GHz and 5GHz) = Dual Next generation AC Wi-Fi
  • 2.4GHz Wi-Fi band = 3×3 11b/g/n/ac
  • 5GHz Wi-Fi band [MU-MIMO] = 4×4 11a/n/ac Wave 2 Wi-Fi

I would rather keep using this router because it’s neater and still excellent for everyone else and everything else in the house.

It may be that AURALiC have a reason why other routers work better - but I would like to know why?

I can’t comment on your previous Netgear device, but I have the TT WiFi Hub and it has generally been issue free.

I upgraded to the Hub from the HG633 which was a lot slower on the wireless side and used it with the Mini until I was satisfied streaming was for me, then I got the Altair.

The only issue I’ve experienced is from TalkTalk’s WiFi “Optimisation” system, which basically caused wireless channels to hop around giving the Altair a very hard time (strangely my other devices were ok). I got that turned off (they have to do it at their end) and all has been fine since.

You have the option in the Hub’s Settings to check signal strength for each device, and rotating the Hub can optimise that aspect.

My signal strength for the Altair gives around 600Mbps which isn’t bad considering it’s the furthest away from the Hub, my iMac which is in the room next door gets 1300Mbps. These figures appear to be good enough to transfer a 1Gb album in under 90 seconds.

The common consensus is that ISP equipment is usually not up to standard and if you require the very best performance that still stands, but I’ve found the Hub to be reasonably good on the wireless side and connection quality (not withstanding the above issue) very good.

If I remember correctly I believe the Mini used to transfer at slightly quicker speeds to my new Altair.

If you are experiencing disconnections I would request that WiFi Optimisation is turned off and also check the signal strength for the Mini, try and get close to -60dBM (smaller the figure the better so -40 is better than -65). If the Mini is on the 5GHz band you could see if moving it to the 2.4GHz improves stability, but that will usually be at the expense of transfer speed.

Hope some of this helps.

Interesting tips thanks - and incredible that someone replied using TT with the same latest Wi-Fi hub too!

I will leave the Mini where it is (I have little choice and it was working perfectly fine ‘sound quality wise’ with the Netgear) - but great to know Wi-Fi optimisation can be turned off! I wonder what the optimisation tries to optimise as such? And ‘why’ it interferes with the Mini and Lightning DS control? I do slide that software volume control up and down on a regular basis so I do need a responsive and reliable Lightning DS app :).

Would another idea be to create two SSID channels - one at 5Ghz and the other 2.4Ghz (I know that was on by default on the Netgear)?

WiFi optimization - I am not with TT but I’ve seen similarly-named features in other routers where they auto change channels to balance traffic and give devices with the heaviest demand the strongest connection. I have it turned off on my router, I don’t think my mini likes it either.

WiFi Optimisation is an ISP controllable process, so the easiest way is to log into the TT forum and then request that an OCE gets it turned off for you, it’s a quick process once they respond to your request.

I believe the process works in addition to the “auto” setting normally found in other routers, the firmware monitors your connections and the surrounding area with respect to interference and other networks, then attempts to move your channel around to achieve “the best” quality signal for your device. That’s ok if the device can keep up with all the “hopping” around but my Altair really didn’t like it, it would stutter a few times during album playback for example, probably due to the need to reacquire the network for track info update.

Yes, having unique SSID’s is usually a good choice, I’ve simply gone into the router settings and for each just appended “-2G” and “-5G” respectively, at least you then know which band you are selecting to join!

I’m not sure why you have issues when using the volume slider, I employ a Pre Amp so leave the slider set to max, and because of that never had that issue.

If the Mini is in reasonable range of the Hub you should get a good signal and therefore that shouldn’t be the reason for the problem, and from what I’ve read it’s wireless strength is up there with the best.

Not sure what else I can add, it’s really a matter of playing around a little and see what you can come up with.

This “Optimisation” appears to be a TalkTalk propriety process, that monitors everything in the surrounding area that’s network related. I believe that info is then sent back to servers for processing, once done your Router channels are then “adjusted” for a “better” connection.

This process appears to be in addition to the “auto” channel selection, which can be turned off, the Optimisation can’t, by the user anyhow.

The big issue is it’s simply not ready for prime time, that may change with firmware updates and changes made at TalkTalk, but the lack of user control is worrying, but probably par for the course regarding ISP’s that have to deal with so many non tech savvy users.

The good side, there forum OCE’s are on the ball so when issues arise they are usually addressed quickly.

a TalkTalk propriety process! How did you know this fact. TBH - TT looks like they are brushing up their service - I’ve got decent speeds at home and the wireless hub is top notch (bar some teething problems that I’m sure can be solved with a few tweaks).

I think one step at a time - turn off the optimisation and see what results - I will soon know if there is an improvement or not.

I’ve read somewhere that AURALiC prefers a good wireless infrastructure over Ethernet - which is interesting.

Struggling right now as I type - the Lightning DS app reads ‘Looking for Device’ without finding it.

It’ll catch up soon I’m sure but it’s this sort of disconnection I am talking about …

Obviously the advantage lies in the galvanic isolation. In my setting SQ was significantly improved when I changed from ethernet to WiFi.

Robin

“Significantly” - wow!

Other manufacturers prefer ‘tethered’ - I’m glad AURALiC recommend Wi-Fi.

Of course your Wi-Fi has to be well sorted for this to be the case (I am currently trying to sort mine out now).

My WiFi is Fritz!Box 7490 based. I wouldn‘t consider any other brand.

If it doesn’t work out (but it should do looking at the specs) with the high quality TalkTalk router, I may in fact go down the AURALiC recommended route - from which I would choose the ASUS RT-AC68U over the others recommended by Xuanqian Wang, simply because it’s better ergonomically for me to have a wireless router stand upright like the TalkTalk one.

His recommendations are 5 Months old now - perhaps he has further recommendations now.

I’m assuming “propriety” because the optimisation is in addition (and TT controlled) to the “auto” channel section that is in the Hub Settings, but that’s just me guessing.

Whatever it is, I agree on your assessment, try and get it turned off and you should notice if it’s worked immediately, but I’m doubtful it’s the cause of your issue.

What I’m struggling to understand is although you get no dropouts during streaming you note periodic disconnections when using the digital volume, even though you believe you now have a better WiFi signal than you did with the previous network setup.

I remember @Xuanqian once explaining LDS uses two protocols and the Router has to be good at both, one for streaming and the other for the control side, and the latter is often the one that can give trouble.

If you never experienced this control issue with the Netgear then even though the Hub is a strong performer streaming wise may be it’s struggling with the control side, but how that’s overcome I’m uncertain. Also I’ve experienced no such issues, being able to control the various options in LDS without problem, I’ve even been moving the digital volume over the last hour to try and get it to freeze up or disconnect, but it all works as it should!

Anyhow, let’s see what happens over next few days and may be others might have some thoughts.

What Wi-Fi setup are you using for such a solid connection like this?

The previous NetGear router never really experienced ‘control’ dropouts - but as a wireless device I would say it’s not actually quite as good at the new TT router.

You are right - when actually streaming music there are zero dropouts with the TT router - it’s just a problem on the control side. I don’t know if it’s possible - but it also seems like the sound quality isn’t quite as good either with the new TT router despite the excellent wireless signal - perhaps I am imagining the latter.

Anyone else experience SQ differences between wireless systems despite having a good Wi-Fi connection?

What would be the physical principles that would cause those differences in SQ?

No idea really - beats me why I think I hear a difference?

Perhaps it’s the processing / processor in the router - how it delivers Wi-Fi - whether the router has a good PSU or not to better the integrity of the Wi-Fi - or perhaps it’s none of that at all because I have no idea. Maybe it’s a TCP / UDP thing associated with the quality of the router.

@Xuanqian save me !

just had sort of a Wi-Fi or Internet odd issue just now - the AURALiC was streaming merrily away but we couldn’t get BBC iPlayer working on either of our iPads?

I switched the router off then on again - problem solved - the AURALiC woke up with Eric Bibb and We Don’t Care from Radio Swiss Jazz - my that sounded brilliant!

I have the Hub upstairs in the front bedroom connected direct to master socket, my Altair is down stairs in the back room, so really it’s the furthest it can be, but I still get the -62bBM signal.

I’m on 5GHz for the Altair, iDevices and iMac which gives good file transfer speed (600Mbps) and stable streaming, a total of 7 devices use the Hub at any one time.

I’ve set wireless channels to fixed (now optimisation is off), 5GHz on channel 100 and 2.4GHz on 11, chosen after inspecting what channels were already being used in the neighbourhood.

The Altair does have two aerials, whether that makes a difference I’m unsure, but the Mini was in the same location also without issue.

The only “fine tuning” I’ve done is to rotate/tilt the Hub to maximum the signal strength received by the Altair, using the Hub’s web interface readings for the Altair’s WiFi stats (screenshot in previous post).

That’s it, there’s nothing else to setup, mainly because the Hub doesn’t have much else to configure.

I’m getting not getting any dropouts from the Mini - but the connection is not as good as yours (see below…). Futher more it’s connected on 2.4GHz. Whether I need a better connection or not is debatable because I don’t stream anything above CD quality.

I’m in a similar situation where the router is upstairs and the Mini is in the lounge downstairs.

I can only assume that the line of sight distance must be far greater than mine, because signal strength on 2.4GHz really needs to be higher, and if it’s on -71 then 5GHz being weaker over distance must have been far lower, I estimate -80 or so, which is really not good enough.

That’s probably the reason you have experienced the dropouts under 5GHz.

Have you tried rotating/tilting the Hub to see if you can improve the signal strength.

Failing that, can you get the Hub closer to the Mini by extending the Hub’s connection from the BT socket, remember it’s line of sight distance so moving the Hub from the front of the room to the back may be enough.

This is another screenshot of my 5GHz connection.

Screenshot 2019-12-21 at 19.11.29

You really need to be on 5GHz for speed and close to -60dBM for stability, at least that’s what I’ve found works in my setup.

If the distance is just too great then you really need a better Router that gives better signal coverage, I believe you can still use the Hub for the Modem side (just turn it’s WiFi side off), then attach the new Router to the Hub which will then provide the WiFi element.

Unfortunately, I’ve never done anything like that myself, but I’m sure others on the forum could talk you through the finer points.