Qobuz major break-down solved

Qobuz stopped working all of a sudden today both on my Aries Mini and my Aries G1.
I tried unsuccessfully on both Aries to log off and then re-log. This does not work .

I tried re-log a number of time , process was always stopping when reimporting user datas.

And after 5th attempt , it worked.

Mystery…

I’m wondering if they have had some issues? I also had difficulties playing Qobuz today, on both my Auralic and on one (?) of my Bluesound units…

You are right,
Yes major server(s) failure(s) right now at Qobuz.
And -as always- they are not communicating on tweeter or facebook.
So better not use Qobuz today!

It appear Qobuz service has back to normal now.

I’m have issues streaming Qobuz today I keep getting unable to play selected track. Logged out and back into both Qobuz and LDS. Tidal and my files stream fine it’s just Qobuz and checked settings they are correctly set to Flac lossless.

All fine here (Germany)

It started working again here too whatever happened it’s over.