My Aries G2 stops playing every 10-30 minutes!

I have an Aries G2 that I bought new 3 weeks ago, and, it has stopped playing music every 10-30 minutes since I got it. I’ve assigned static IPs to my Roon core (windows computer), and my G2. I have tried it wired and wirelessly, makes no difference. My network is a Ruckus that has a WIFI speed of 150Mb/sec. Any ideas?
Last time it dropped, I got a message that Roon lost control of the device because the output channel had been changed. Running it with a coax cable now, seems stable. I was using usb before. I prefer the usb cable.

What is your DAC ?
Can you try the HDD output instead of DAC one and check if you have the same issue ?

DAC is ps audio directstream. There is no hard drive in my Aries, will HDD output work?
Thanks for responding @deuch.

Yes, the HDD ouput works with a DAC. It’s just lack the galvanic isolation. I’ve done testing like that with my DAC and it works fine.

@deuch, I’ll give that a try. Thanks
Last night, I used the same ethernet connection to run Roon through my PS Audio Bridge2, and, it ran flawlessly for 8 hours.

I still have not figured out why my Aries G2 stops playing every 10-30 minutes. My other streamer works fine on the same ethernet connection.

Have you tried it wirelessly?

If it works wirth coaxial and your Aries G2, it’s not an ethernet issue.
If you have issue with USB, try first the HDD output.

It can be an incompatibility issue with USB and your DAC or a faulty USB port of the Aries.

@daeOne, I have tried WIFI, drops the same.
@deuch, I will try the HDD usb when I get a chance. Coaxial dropped too, just took longer. My PS Audio Dac is recognized by the Aries. I’ve tried my WW platinum starlight usb, and, the usb cable that came with the aries, both drop regularly.
I’m thinking it must be a faulty usb module in the Aries, my other streamer works flawlessly on the same network, using the same cables.

I had my Aries G2 connected via to a DSD sr. for three months. It might of dropped twice in that time.
Something must be faulty.

Yes, I’m thinking the same thing. Thanks

Here are shots of my device setup and signal path.


Thanks for your help.

Make sure your G2 is set to PCM Auto Detect, this will make sure the USB connection is correctly configured.
And, by the way, you have set the PS Audio as an MQA capable DAC, it is not. You also should set volume to “Fixed”.

@AlfaGTV AlfaGTV, thanks for your help. G2 was set to PCM auto detect. I changed the PSA DSD to renderer, and volume on G2 to Fixed.
I’ll run it for a while and see how long it will play continuously.
Thanks again.

Nothing has changed. Aries G2 still won’t play for more than 60 minutes without stopping. Which is really a shame! The unit sounds incredible while it works LOL. Best source I’ve ever had, except for the stopping midway through a song!

I have another suggestion, in the Streaming section, disable Bluetooth and Airplay and just keep Roon Ready as input channel while investigating.
I have seen strange things happen while BT and Airplay was active!
Atb /Mike

Ps The PS Audio is no MQA renderer either afaik?

Does it happens with all kind of file ? DSD, flac etc ???

It can be an issue with the buffer too. It seems a bug exist with memory leak if your are playing file that are bigger than 1.1Gb

@AlfaGTV, I shut that stuff off yesterday, I was thinking the same as you. I also shut off bluetooth on my ipad, and turned off the sharing between ipad and other apple devices. It seems I may have solved the issue! The G2 ran for about 6 hours straight last night, and, is going well this morning. Fingers crossed!
Thanks to all that chimed in, for your help!

1 Like

@deuch, I don’t have dsds. Thanks for helping!