5.2 firmware is now alive


#1

We are expecting this version to resolve several network related issue.


#2

Just installed this morning. Had one lockout with the Aries showing the network sign in the display window. Did a power reset and appears to be stable now. Not sure if it’s just the placebo effect, but there seems to be a definite improvement in the sound quality. Better separation between instruments, more detail and clarity. A touch smoother too. Am I imagining it???


#3

What about us with “only” an Aries Femto?
Are we still going to wait and hope?


#4

Is beta firmware enabled? My Aries had downloaded 5.2 before I saw an announcement.


#5

Ups!
Did not see it was a beta.
I have not (and do not want to have) beta versions.
Would appreciate an official statement about when we (owners of Aries) can expect a new firmware.


#6

I noticed some improvement to SQ too which is right direction :+1:


#8

@Xuanqian

There’s a big noticeable SQ difference btw 5.1 vs 5.2 after listening for a while. I’m curious what have you change in the firmware that resulted in a big improvement in SQ? I can described as better imaging, there’s more ‘air’ in the upper registers and better separation btw instruments. Vocals have ‘weights’ or thicker and smooth sounding.


#9

AirPlay is dropping out a lot. Aries.

Help!


#10

SQ is clearly enhanced versus 4.1, but the wifi problems are not fixed. As @jacs already described, the device gets disconnected from the network on a multiple of 10 minutes interval. Router log shows this happens at the same time to other devices, but these devices reconnect immediately to the network (ipad, iphone). @Xuanqian : Have you done some investigation on the possible miss of WPA2-CCMP group key change which leads to device exclusion. There are statements from AVM (router manufacturer) and HP for wireless printers on this topic. HP avoids this through setting their printer-internal server to a compatible behavior for 802.11 b+g networks.

Had yesterday three crashes, all related to “device disconnected, because it is not responding”

Thanks and regards!


#11

Hi there, updated Aries Mini to v5.2 last weekend and unit response times and SQ improved. Changing filters now makes an audible change on my system. Impressed. I experienced couple of WiFi drops which were not present with v4.1, nothing else changed in my infrastructure. All in all it’s a job well done.


#12

Hi Troy:

Can you please give more information about WPA2-COMP?


#13

This updates only includes bug fixes, we did not include any new functions. Maybe the bug fixes bring positive sound quality change.


#14

I am using Aries Femto; connected via Ethernet to a QNAP NAS; after upgrade to 5.2 - periodic drop offs: “Device not found”; after this it was not possible to turn off the device; only with the on/off switch from the power supply. Uninstalled the beta, it’s not funny with this behavior.


#15

Please reboot your WiFi router


#16

Thanks for the advice; rebooting after updating to 5.2?


#17

It does not matter if it is before or after. I think you can just try to reboot the WiFi router


#18

Sorry reboot the WiFi Router did not solve the problem; while streaming
music is still playing, but the display does not show the progress, also
the time is “frozen”; playing stops then and only the use of the off/on
switch from the power supply is able to restart the aries.
With 4.1 are no problems.
Kind regards


#19

Hi:

If in this case, I would suggest to stay with 4.1 firmware till the new version is more stable. This is also the reason why we still not yet release it to official version.


#20

You are right — I wait until the 5.X is stable.
Kind regards


#21

december 7th 2017, here (France) and FW5.2 cause a problem : Altair with 7260HMW wifi card stuck on “STARTING…” when going from sleeping.
My router is a Netgear NightHawk R7000 (AC 1900) but tried with a D-Link & a TP-Link : same results.
No solution else power off from the AC & revert back on.
Work fine else but this “wifi recovery after sleep” nightmare doesn’t occurs with the earlier versions of the firmware.
Do you plan to solve the 7250HMW FW5.2 issue in a near future ?
Regards.